Mono 4 for CentOS5   June 11th, 2015

As you may have noticed, the Mono packages provided by Xamarin won’t work on CentOS5, because some libraries are too old.

Yesterday, I realized that my Mono build for CentOS5 was still on version 3.12.1.

So I updated my Mono packages on LBS, and we have the latest Mono 4.0.1.44 available for CentOS5 now.

To install it, follow the instructions at https://lbs.solidcharity.com/package/tpokorra/mono/mono-opt:

wget https://download.solidcharity.com/repos/tpokorra/mono/centos/5/lbs-tpokorra-mono.repo -O /etc/yum.repos.d/lbs-tpokorra-mono.repo
yum install mono-opt mono-opt-devel

To use it, you need to call the environment script first (mind the space between the dot and the slash…):

. /opt/mono/env.sh
Tags: , ,
Posted in Software Development | Comments Closed